Error 740 when launching MT4

Modified on Tue, 11 Jul 2017 at 06:22 PM

Symptoms


When trying to launch Metatrader 4 after installing the Tick Data Suite, you get a message box saying "Unable to create MT4 process. Error 740"; when clicking the Ok button, the application fails to start.


Cause


This happens because your Metatrader 4 executable is configured to run as an administrator which is typically not necessary.


Resolution


There are a few potential solutions for this. The one I would recommend is #1, removing the Run as administrator flag from terminal.exe. Running it as an administrator is only necessary if you are using the /portable command line switch and the installation location is in an UAC-protected folder - if that is your case, I suggest simply moving it to a non-UAC-protected location such as your desktop or a non-system drive.


Solution #1 - disable the Run as administrator flag for terminal.exe:

  1. Locate your terminal.exe. One way to do that is by right clicking the shortcut you use to start it, opening the Properties dialog and clicking the Open file location button.
  2. Right click terminal.exe.
  3. Open the Properties dialog.
  4. Switch to the Compatibility tab.
  5. Disable the Run this program as an administrator checkbox.


Solution #2 - enable the Run as administrator flag for TDSLoader.exe, assuming you installed in the default location:

  1. Open Windows Explorer.
  2. Browse to C:\Program Files (x86)\eareview.net\Tick Data Suite\. If you're on an x86 system, you will have to go to Program Files instead of Program Files (x86).
  3. Right click TDSLoader.exe.
  4. Open the Properties dialog.
  5. Switch to the Compatibility tab.
  6. Enable the Run this program as an administrator checkbox.

Note that if you have UAC enabled solution #2 will prompt you to grant administrative permissions every time you start MT4.


Solution #3 - force the Tick Data Suite to load via a kernel driver:

  1. Run the Tick Data Suite support assistant (from your Start menu).
  2. Open the Settings tab.
  3. Click the Stop TDS Service button. Provide administrative permissions if prompted.
  4. Enable the Load the Tick Data Suite via kernel driver checkbox.
  5. Click the Start TDS Service button. Provide administrative permissions if prompted.